OMNIBOT 2000 ASSISTANCE NEEDED PLEASE!


[ Follow Ups ] [ Post Followup ] [ Mike's NEW Omnibot's Message Board ] [ FAQ ]

Posted by Sam Chambers NY. (204.97.7.203) on February 25, 2005 at 00:05:03:

i just got a omnibot 2000 that needs help and i believe he does not function correctly.i fully charge his new battery but when i push the directional buttons forward or backward his red battery charge light flickers and when you are having him turn left or right the red battery charge light stays on until you stop him from turning left or right.none of the other buttons makes the red battery charge light come on just the directional buttons.is this normal for a omnibot 2000 or what.also my omnibot 2000 has another problem he will only travel a few feet away like 10 feet then he starts jerking stopping and unresponsive to commands on the remote.someone told me he is suppose to travel 25 to 50 feet away.i turned everything off in the house thinking that something is interfering with the signal but its still only 10 feet he will travel and the jerking and stopping happens again.can these problems be fix, is it the robot or the remote thats causing the problem.please HELP i paid a arm and leg to get him.


Follow Ups:

  • Re: OMNIBOT 2000 ASSISTANCE NEEDED PLEASE! Service 23:16:04 02/25/05 (0)

    Post a Followup

    Name:
    E-Mail:
    A -nospam- will be placed after the @
    Subject:
    Message:
    Optional Link URL:
    Link Title:
    Optional Image URL:


    [ Follow Ups ] [ Post Followup ] [ Mike's NEW Omnibot's Message Board ] [ FAQ ]